ホーム > Linuxで自宅サーバ(CentOS) > またも。。yumのPHP自動アップデートで問題が。。要ダウングレード

またも。。yumのPHP自動アップデートで問題が。。要ダウングレード

2013 年 8 月 4 日 こてつ コメントをどうぞ コメント

??ECサイトのプルダウンメニューが出てこない。

調べてみるとやっぱりyumのアップデート後だ。


PHP5.3.26 から PHP5.4.17 にアップデートされています。

その日からでしょう。おそらく。

たぶんバージョンが上がったことにより動かないスクリプトか何かが。。

対応策をねる時間が無いので。。phpをダウングレードします。

<参考>
CentOS 5.5 php5.3.6からphp5.2.17へyumでダウングレード
yumで簡単にphp 5.3からphp 5.2にダウングレード

downgrade コマンドを試してみましたが上手くいかなかったので

yumでアンインストール、ダウングレードのインストール。。という手順を行いました。

<以下覚書>。。間違いがある可能性もかなりあります。。

現在のphp関連パッケージを調べる。

# yum list installed | grep php
php.x86_64 5.4.17-23.el5.art installed
php-cli.x86_64 5.4.17-23.el5.art installed
php-common.x86_64 5.4.17-23.el5.art installed
php-devel.x86_64 5.4.17-23.el5.art installed
php-gd.x86_64 5.4.17-23.el5.art installed
php-mbstring.x86_64 5.4.17-23.el5.art installed
php-mcrypt.x86_64 5.4.17-23.el5.art installed
php-mysql.x86_64 5.4.17-23.el5.art installed
php-pdo.x86_64 5.4.17-23.el5.art installed
php-pear.noarch 1:1.7.2-2.el5.art installed
php-pgsql.x86_64 5.4.17-23.el5.art installed
phpmyadmin.noarch 2.11.11.3-2.el5.rf installed

5.4.17-23 となっています。 こいつを5.3* にバージョンダウンする。。

とりあえず、現phpアンインストール

# yum remove php php-common php-cli php-pdo php-pgsql php-gd php-devel php-mbstring php-mcrypt php-mysql

※ /etc/httpd/conf.d/php.conf は /etc/httpd/conf.d/php.conf.rpmsave として保存される。
※ /etc/php.ini は /etc/php.ini.rpmsave として保存される。
※ /etc/httpd/conf.d/phpmyadmin.conf は /etc/httpd/conf.d/phpmyadmin.conf.rpmsave として保存される。
。。らしいので確認しなきゃいけないかな。。

RPMのバージョンを確認
64bit http://rpms.famillecollet.com/enterprise/5/olds/x86_64/

remiにあるバージョン で php5.3.23-1 にすることにしました。

必要なファイルをダウンロード

wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-cli-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-common-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-devel-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-gd-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-mbstring-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-mcrypt-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-mysql-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-pdo-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-pgsql-5.3.23-1.el5.remi.x86_64.rpm
wget http://rpms.famillecollet.com/enterprise/5/olds/x86_64/php-pear-1.9.4-7.el5.remi.noarch.rpm

 
yumでバージョン指定してphpをインストール

# yum install --enablerepo=remi php-common-5.3.23* php-cli-5.3.23* php-5.3.23*

 
php関連モジュールをインストール

# yum install --enablerepo=remi php-gd-5.3.23* php-mbstring-5.3.23* php-mcrypt-5.3.23* php-mysql-5.3.23* php-devel-5.3.23* php-pdo-5.3.23* php-pgsql-5.3.23*

 
その他追加分

# yum install -y php-pear.noarch phpmyadmin.noarch

 
完了。httpd再起動。再度確認。

]# yum list installed | grep php
php.x86_64 5.3.23-1.el5.remi installed
php-cli.x86_64 5.3.23-1.el5.remi installed
php-common.x86_64 5.3.23-1.el5.remi installed
php-devel.x86_64 5.3.23-1.el5.remi installed
php-gd.x86_64 5.3.23-1.el5.remi installed
php-mbstring.x86_64 5.3.23-1.el5.remi installed
php-mcrypt.x86_64 5.3.23-1.el5.remi installed
php-mysql.x86_64 5.3.23-1.el5.remi installed
php-pdo.x86_64 5.3.23-1.el5.remi installed
php-pear.noarch 1:1.7.2-2.el5.art installed
php-pgsql.x86_64 5.3.23-1.el5.remi installed
phpmyadmin.noarch 2.11.11.3-2.el5.rf installed

remiリポジトリが導入されていることが前提です。確認は。。「# yum repolist all」。。かな?
 

そうそう。

[warn] module php5_module is already loaded, skipping

 
というエラーが出たので。。
先日 /etc/httpd/conf/httpd.conf に追加したばかりの LoadModule をコメントアウト。

# LoadModule php5_module modules/libphp5.so

 
今回のインストールで「/etc/httpd/conf.d/php.conf」のものと重複になったみたいです。

 

立て続けにサーバー運用に支障が出たyumの自動アップデート。。停止や除外設定が必要かなぁ。。

 

スポンサード リンク
 

 
カテゴリー: Linuxで自宅サーバ(CentOS) タグ:

Yahoo!ブックマークに登録 はてなブックマークに登録 Deliciousに登録 livedoorクリップに登録 Buzzurlに登録 mixiチェック Facebookにシェア ツイートする