ホーム > Linuxで自宅サーバ(CentOS) > phpでなんか怒られた

phpでなんか怒られた

2012 年 2 月 16 日 こてつ コメントをどうぞ コメント

プログラムインストールしようとしたら何かエラーが出ました。

何コレ?

Warning: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Asia/Tokyo' for 'JST/9.0/no DST' instead in /var/www/html/mm/data/module/Smarty/libs/Smarty_Compiler.class.php on line 400

調べてみたらPHP5.1.0からデフォルトタイムゾーンを設定しないといけないそうな。


PHPの日付関数でWarningエラー

対策1. date_default_timezone_set関数で定義する

date_default_timezone_set('Asia/Tokyo');

対策2. php.iniで設定する

date.timezone = Asia/Tokyo

とりあえずphp.iniで設定しときました。

 

スポンサード リンク
 

 
カテゴリー: Linuxで自宅サーバ(CentOS) タグ:

Yahoo!ブックマークに登録 はてなブックマークに登録 Deliciousに登録 livedoorクリップに登録 Buzzurlに登録 mixiチェック Facebookにシェア ツイートする

  1. コメントはまだありません。
  1. トラックバックはまだありません。